Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Problem z Repetierem (?)
#41
U mnie kompiluje się bez problemu Oczko Poza tym masz jakiegoś starego Marlina. Pobierz najnowszego stąd: https://github.com/MarlinFirmware/Marlin

Kliknij "Clone or Download" i wybierz ZIP. Nie ma co się pchać w starego Marlina w szczególności, że one są ulepszane i łatane Uśmiech
>> Nie pomagam na PW. Od tego jest forum Uśmiech >> Koniecznie sprawdź: Jak dodawać załączniki

1 problem = 1 wątek
Odpowiedz
#42
Pokombinowałem i rzeczywiście, udało się w końcu wgrać Marlin już skonfigurowany i bez błędu. Pobrałem go na nowo z linku który wstawiłeś. Dobre jest to że z tego linku pobierałem tą samą wersję kilka dni wcześniej ale jakimś cudem musiało pobrać starego Marlina (ciekawe jak) no ale to już rozwiązane. 

No i kolejne problemy...

1.Gdy chcę drukować z Repetiera: 
a)Zadaje błędną temperaturę głowicy i stołu, mimo że poprawne są podane i w slicerze i w menu Repetiera. Bierze jakąś nie wiadomo skąd, 240 na ekstruder (potrzebuję max. 190 na PLA) i 95 na stole (z czego do 95 stół nie może dociągnąć...). 
b)Grzałka ekstrudera nie chce się rozgrzać po poleceniu od Repetiera, mimo że w tym samym czasie łoże nagrzewa się bez problemu 
c)Na ekranie LCD nie wyświetlają się zadane temperatury przez Repetier, ani też obecne. Jedyne miejsce gdzie podczas druku z Repetiera mogę sprawdzić temperatury to sam Repetier.
2.Gdy chcę drukować z karty SD:
a)Po wgraniu na kartę g-codu, drukarka nie podgrzewa zdalnie głowicy/stołu, tylko od razu jedzie jakby "na sucho"
b)Zrobiłem zgodnie z poradnikiem kalibracji - kartka papieru ma się mieścić między głowicą a stołem - co z tego skoro g-code nakazuje odsunięcie Z o 0.3mm w związku z czym głowica w ogóle nie dotyka stołu
c)Podczas wybierania opcji "automatyczna pozycja zerowa", mimo wpisania w oprogramowanie Ymin=10, drukarka dojeżdża na 0 i stamtąd chce rozpoczynać ruch jałowy

Załączam znów Marlin, tym razem ten działający. Nie mam pojęcia tak naprawdę skąd drukarka bierze polecenia - czy od Marlina, Repetiera czy od slicera, bo w sumie w każdym z tych trzech mogę ustawić np. Ymin czy temperaturę głowicy, co powoduje że nawet nie wiem w którym miejscu zmieniać wartości aby drukarka w końcu coś wydrukowała a nie wykonywała powyższe dzikie ruchy.

Wiem że tego dużo, ale to są moje problemy po zrobieniu dokładnie wszystkiego z kalibracją, a mimo to nadal nie mogę nic wydrukować...


Załączone pliki
.rar   Marlin-RC.rar (Rozmiar: 1.24 MB / Pobrań: 2)
Odpowiedz
#43
Marlin wygląda dobrze. Podeślij zdjęcia konfiguracji filamentu ze slic3ra. Odnośnie 2b to głowica nie ma dotykać stołu, bo wtedy będzie rozcierać pierwszą warstwę. Spróbuj usunąć całego repetiera (sprawdź czy nie zostały jakieś pliki po odinstalowywaniu; jak tak to je też usuń, z wyjątkiem ustawień slic3ra) bo może masz coś namieszane, bo to jest aż dziwne, że nie działa. Bo to powinno bez problemu działać i pokazywać aktualne dane z druku.
>> Nie pomagam na PW. Od tego jest forum Uśmiech >> Koniecznie sprawdź: Jak dodawać załączniki

1 problem = 1 wątek
Odpowiedz
#44
Już nie mam siły... przeinstalowałem repetiera i teraz dla odmiany znów nie działa... gcode cały czas wykonuje się na Z0.3mm, szukałem czy coś zadaje tą wartość w ustawieniach ale nie. Przez to Z0.3mm filament nie ma szans na dotknięcie stołu, czyli rozpoczęcie druku. Chciałbym coś w końcu wydrukować 2 tygodnie od złożenia ale chyba się nie uda.
Odpowiedz
#45
Jeżeli druk się zaczyna na wysokości 0,3mm to wszystko jest w porządku. Jeżeli na tej wysokości filament nie dotyka stołu to znaczy, że ekstruder podaje za dużo filamentu, albo enstop osi Z jest za wysoko
>> Nie pomagam na PW. Od tego jest forum Uśmiech >> Koniecznie sprawdź: Jak dodawać załączniki

1 problem = 1 wątek
Odpowiedz
#46
Znów minęło kilka dni bez druku i bez żadnych rezultatów.


Podsyłam zdjęcia z ostatniej próby druku - z karty SD, po tym jak sam ręcznie zadałem temperaturę a potem kazałem odpalić g-code z karty. Nie mam pojęcia po jasną cholerę jest 0.3mm z osi Z skoro przez to po prostu filament nie dotyka stołu.


Załączone pliki Miniatury
       
Odpowiedz
#47
A po taką, że to jest pierwsza warstwa. Na nią jest "lane" więcej filamentu, żeby przylgła do stołu. Wejdź w konfigurację Slic3ra i zakładkę "Printer Settings". Następnie przejdź do sekcji "Custom G-code" i tam ustaw dla:

start:
Kod:
G28 ; home all axes
G92 E0
G1 E3 F1200
G1 E2 F1200
G92 E0

i end:
Kod:
G1 X12.0 F4000
GI Y170 F4000
M104 F0
M140 S0
M84

A następnie zapisz ten profil Uśmiech

   
>> Nie pomagam na PW. Od tego jest forum Uśmiech >> Koniecznie sprawdź: Jak dodawać załączniki

1 problem = 1 wątek
Odpowiedz


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Problem z Oś Z Ergas101 1 860 13-05-2017, 16:30
Ostatni post: feriar
Wideo Problem z silnikami zawaartur 11 3,129 25-10-2016, 10:31
Ostatni post: feriar

Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości