Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
NodeMCU v2 ESP8266 - problem z podłączeniem/programowaniem
#1
Cześć,
chciałem rozpocząć swoją przygodę z rodziną mikrokontrolerów ESP, a w tym celu kupiłem na allegro NodeMCU v2. Niestety nie jestem w stanie podłączyć jej celem zaprogramowania.
Komputer na którym pracuję ma system Windows 10 x64.

1. Instalowałem sterowniki:
https://www.silabs.com/products/mcu/Page...ivers.aspx

2. Instalowałem sterowniki CH341SER

3. Próbowałem zwierać ze sobą piny GND -> GPIO0 - różnica jest taka, że niebieska dioda nie miga, ale komputer nie wykrywa sprzętu

4. Próbowałem zwierać GND -> GPIO15, żeby wymusić baud rate 9600 (idąc za radą kilku zagranicznych forów)

5. Próbowałem też oczywiście kombinacji gdzie zarówno GPIO0 i GPIO15 były zwarte do GND

Wydaje mi się że płytka jest ok, podłączając płytkę po prostu po kabelku to zgodnie z opisem tego co dziać się powinno mruga niebieska dioda, a komputer wykrywa sieć o nazwie ESP8266, z którą też mogę się połączyć.
Próbowałem łączyć się z płytką za pomocą programów:
1. ESP8266Flasher - nie wykrywa żadnego portu COM
2. LuaLoader - wykrywa porty COM2 i COM4 - nie łączy się z żadnym
3. Arduiono  - mam wyszarzoną opcję wyboru portu, czyli chyba żadnego nie wykrywa
4. Putty - nie wykrywa żadnego portu i nie łączy się z COM2 i COM4 wykrytymi przez flashera.

Każdy z tych programów próbowałem również uruchamiać jako administrator. Skończyły mi się już pomysły. Może jest coś oczywistego o czym nie wiem.
Z góry dziękuję za pomoc.
Odpowiedz
#2
przy Flasherze ważne jest aby taki sam jak system czyli 32 albo 64 bitowy. W przeciwnym wypadku może nie wykrywać modułu albo podczas wgrywania będzie błąd.

No i przy NodeMCU nie trzeba niczego zwierać

Wysłane z mojego m2 note przy użyciu Tapatalka
>> Nie pomagam na PW. Od tego jest forum Uśmiech >> Koniecznie sprawdź: Jak dodawać załączniki

1 problem = 1 wątek
Odpowiedz
#3
Po kolejnym dniu walk doszedłem jedynie do tego, że w managerze urządzeń nie wyświetlało się nic, mimo wielokrotnego instalowania sterowników. Poszedłem więc drogą opisaną na jakiejś stronie żeby wejść w managerze urządzeń i dodać manualnie urządzenie i ścieżką którą starsi mogą pamiętać z windowsa 98 zainstalowałem sterowniki wskazując folder w którym są umieszczone. Od teraz mam wreszcie urządzenie w managerze, ale z błędem. Błędem dokładnie takim jak tutaj: https://www.silabs.com/products/mcu/Page...ivers.aspx tylko na Win10. Próbowałem ze starszymi wersjami sterowników oraz z najnowszą. Niestety bez skutku.
Odpowiedz
#4
Na stronie nie zauważyłem żadnego opisanego błędu.

Wysłane z mojego m2 note przy użyciu Tapatalka
>> Nie pomagam na PW. Od tego jest forum Uśmiech >> Koniecznie sprawdź: Jak dodawać załączniki

1 problem = 1 wątek
Odpowiedz
#5
Przepraszam, wkleiłem zły link:
Nie można uruchomić urządzenia. Kod 10.

http://community.silabs.com/t5/Interface...d-p/115901
Odpowiedz
#6
Spróbuj może w biosie zablokować port COM jeżeli masz taką opcję. Próbowałeś instalować sterownik dla PL2303 ? Zobacz tutaj:
http://feriar-lab.pl/sterowniki-do-przej...32-com-na/
>> Nie pomagam na PW. Od tego jest forum Uśmiech >> Koniecznie sprawdź: Jak dodawać załączniki

1 problem = 1 wątek
Odpowiedz
#7
Próbowałem instalować sterownik który podałeś - nic się nie zmieniło. Próbowałem też sterownik polulu, próbowałem też na wszystkich możliwych portach USB. W uefi nie mam żadnych ustawień dotyczących portów COM.
Odpowiedz
#8
Ze względu na to, że mamy te same systemy to u siebie też odinstalowałem sterownik i zainstalowałem od nowa i działa jak należy, ale do rzeczy. Spróbuj w menadżerze urządzeń odinstalować sterownik i jak Ci się pokaże urządzeń z żółtym trójkątem to kliknij na nie prawym przyciskiem i "aktualizuj oprogramowanie sterownika", a następnie 1. opcja " Wyszukaj automatycznie...".
>> Nie pomagam na PW. Od tego jest forum Uśmiech >> Koniecznie sprawdź: Jak dodawać załączniki

1 problem = 1 wątek
Odpowiedz
#9
Niestety bez zmian Smutny Próbowałem z rebootem po odinstalowaniu i bez.
Odpowiedz
#10
Teraz gdy zrobiło się ciemniej w pokoju poraz pierwszy zauważyłem że obok układu CP2101 nieśmiało coś świeci. W zależności od tego jak docisnę kabel USB świeci bardzo słabiutko (niezauważalnie w dzień), lub nieco mocniej.
Czy to dobrze, czy to źle i jak powinno być?

Link do zdjęcia z zaznaczonym miejscem: https://zapodaj.net/eb60f56ad69dc.jpg.html 

Tego kabla używam wyłącznie do tego kontrolera. Specjalnie po to go kupiłem, nie mam telefonu i niczego innego z takim kablem, żeby to łatwo sprawdzić czy to jego wina. Wścieknę się jeżeli to taki banał Smutny
Odpowiedz


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości