Ocena wątku:
  • 1 głosów - średnia: 5
  • 1
  • 2
  • 3
  • 4
  • 5
Stacja lutownicza ArduSolder
#21
Kolega na rctruck.pl znalazł błąd, otóż nie zmieniłem pina do którego podłączzny jest PID, jest PIDPin 7 a powinien być np. 6 bo 7 nie jest PWM. Nie ma to wpływu istotnego na działanie stacji bo i tak ładnie ustawia temperaturę, ale żeby było po bożemu to powinna być płynna regulacja Uśmiech

Nalezy zmienić to :

Cytat:/* ArduSolder - stacja lutownicza by Sławek RCTRUCK.PL

 http://rctruck.pl/forum/viewtopic.php?f=60&t=2662
Sprzedaż i działaność zarobkowa wykorzystująca niniejszy kod, bez zgody autora, jest surowa zabronioa.

Wersja 0.9.6 z dnia 2015.12.19

*/

String wersja="0.9.8";

#if defined(ARDUINO) && ARDUINO >= 100
#include "Arduino.h"
#else
#include "WProgram.h"
#endif
#include <Wire.h>
#include <LiquidCrystal_I2C.h>
#include <max6675.h>
#include <PID_v1.h>

#define I2C_ADDR    0x27
#define BACKLIGHT_PIN 3
#define En_pin  2
#define Rw_pin  1
#define Rs_pin  0
#define D4_pin  4
#define D5_pin  5
#define D6_pin  6
#define D7_pin  7

// numery PIN
int przyciskPin = 8;
int PIDPin = 7;
int ktcSO = 11;
int ktcCS = 10;
int ktcCLK = 9;
int potencjometrPin = A0;
int zasilaniePin = A3;

Na to :

Cytat:/* ArduSolder - stacja lutownicza by Sławek RCTRUCK.PL

 http://rctruck.pl/forum/viewtopic.php?f=60&t=2662
Sprzedaż i działaność zarobkowa wykorzystująca niniejszy kod, bez zgody autora, jest surowa zabronioa.

Wersja 0.9.6 z dnia 2015.12.19

*/

String wersja="0.9.8";

#if defined(ARDUINO) && ARDUINO >= 100
#include "Arduino.h"
#else
#include "WProgram.h"
#endif
#include <Wire.h>
#include <LiquidCrystal_I2C.h>
#include <max6675.h>
#include <PID_v1.h>

#define I2C_ADDR    0x27
#define BACKLIGHT_PIN 3
#define En_pin  2
#define Rw_pin  1
#define Rs_pin  0
#define D4_pin  4
#define D5_pin  5
#define D6_pin  6
#define D7_pin  7

// numery PIN
int przyciskPin = 8;
int PIDPin = 6;
int ktcSO = 11;
int ktcCS = 10;
int ktcCLK = 9;
int potencjometrPin = A0;
int zasilaniePin = A3;

No i oczywiście fizycznie podłączyć pod pin 6 a nie 7 Uśmiech

Pozdr
Nie wdawaj się w rozmowę z głupim. Najpierw sprowadzi Cię do swojego poziomu, a później pokona doświadczeniem.
Odpowiedz
#22
Wprowadziłem zmiany, skompilowałem i nie było błędów... chyba jestem hakerem Oczko
Odpowiedz
#23
Panowie mam problem. Dziś złożyłem sprzęt aby przygotować do wmontowania w obudowę. No i ze zmianami w oprogramowaniu jest kaprys. Mianowicie, po osiągnięciu zadanej temperatury wyskakuje komunikat o odłączonej kolbie, po sekundzie napis znika a status zmienia się na OFF. Gdy przywrócę z pinu 6 na 7 wszystko wraca do normy.
Odpowiedz
#24
Hmm, nie wiem co to może być, ja mam na pinie 7 i działa ok, co prawda nie ma płynnej regulacji mocy bo to nie jest pełny PWM ale po nagrzaniu głowicy szybko stabilizuje temp. do ustawionej w odchyłce +/- 1 st. C co moim zdaniem jest bardzo dobrym wynikiem Uśmiech zatem proponuje zmienić na pin 7 i nie zawracaj sobie głowy Uśmiech

Pozdr
Nie wdawaj się w rozmowę z głupim. Najpierw sprowadzi Cię do swojego poziomu, a później pokona doświadczeniem.
Odpowiedz
#25
Tak zrobię. Nie ma to dla mnie wielkiego znaczenia. Do tej pory używałem chińskiej kolby z zerową kontrolą temperatury, która grzała się do tego co jest na powierzchni słońca. Tak więc taki problem to nie problem Oczko
Odpowiedz
#26
Dziś zabrałem się za obudowę... i zmieniłem koncept. Wczoraj wieczorem całość wmontowałem w przeźroczystą pleksę, ale szczerze przyznam, że jakoś się nie prezentowała. Nie mam tutaj na myśli projektu obudowy Sławka, gdyż jest ona superfunkcjonalna i bardzo dobrze się sprawdziła. Chyba nie jestem designerem wnętrzności i nie udało mi się zaprezentować całości w odpowiednio przystojny sposób :Uśmiech hehe 
Tak więc suma sumarum postawiłem na przedwojenny zasilacz, mam takie dwa i jeden z brzydszych braci zostanie znów powołany do życia. Nie używam ich i trochę zagracają graciarnie.
Dziś go wybebeszyłemm wyciąłem okienko. Jutro wiercę dziurki na przycisk ON/OFF i potencjometr. Może uda się pomalować oszczędzając tabliczkę znamionową.


Załączone pliki Miniatury
   
Odpowiedz
#27
Wow, superancki zasilacz (właściwie obudowa). Jak wyczyścisz i ładnie wszystko upakujesz to będzie wyglądać dosyć oryginalnie Duży uśmiech
>> Nie pomagam na PW. Od tego jest forum Uśmiech >> Koniecznie sprawdź: Jak dodawać załączniki

1 problem = 1 wątek
Odpowiedz
#28
Witam lutownica działa pieknie Uśmiech Wczoraj doszły wszyskie  części, została tylko obudowa do zrobienia .
Do ideału brakuje mi buzera sygnalizującego  osiągniecie zadanej temperatury Uśmiech
Odpowiedz
#29
może zamiast buzzera lepsza byłaby migająca dioda ? a jaką obudowę planujesz ?
>> Nie pomagam na PW. Od tego jest forum Uśmiech >> Koniecznie sprawdź: Jak dodawać załączniki

1 problem = 1 wątek
Odpowiedz
#30
Z czarnej plexy- wielką Uśmiech.Kolega ma drukarke 3d ale chyba za drogo by wyszła taka obudowa .
Kupiłem pompke z centralnego zamka 412773 003572 VOLVO S40. Jest troche za słaba , ale może nada się na rozlutownice.
Idealnie nadaje sie do podnoszenia układów bga. Ale czy da rade z cyną zobaczymy . Jest bardzo tania 10+20 wysyłka na allegro.
Buzzer miałem w swojej pierwszej lutownicy zhaoxin 936d i bardzo mi brakuje po zmianie na Quick 706. Uśmiech
Odpowiedz


Skocz do:


Użytkownicy przeglądający ten wątek: 2 gości