Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Kurs Arduino #14 problem
#11
(04-01-2018, 22:58)Aratron napisał(a):
(04-01-2018, 01:32)feriar napisał(a):
(03-01-2018, 20:50)Aratron napisał(a): Trochę się wyjaśniło. Podłączyłem moduły nrf przez dwa Arduino Uno i komunikują się ze sobą bez problemu. Stwierdziłem więc że nie są w stanie dogadać się między Arduino nano i Uno. Jednak dwa Arduino nano również się nie komunikują. Czy macie pomysł co może być problemem? Zakupiłem całkiem pokaźną ilość nano a chciałbym je wykorzystać w komunikacji.

Pozdrawiam Uśmiech

Ja bym sprawdził czy w ich konfiguracji, tzn. napięcie i częstotliwość wynosi odpowiednio 5V i 16MHz. Bo może być tak, że w wyborze procesora jest przestawiony na 3,3V i 8MHz co może powodować problemy ze stabilnością układu.

A gdzie można to sprawdzić/zmienić? Bo narzędziach w zakładce z procesorami nie ma nic podane.  Huh


Aha, faktycznie bo to są nano to nie można im tak ustawić (pro mini mają taką funkcję) :/ . Powiedz jeszcze jakim napięciem zasilasz Arduino i nRF
>> Nie pomagam na PW. Od tego jest forum Uśmiech >> Koniecznie sprawdź: Jak dodawać załączniki

1 problem = 1 wątek
Odpowiedz
#12
(05-01-2018, 00:38)feriar napisał(a):
(04-01-2018, 22:58)Aratron napisał(a):
(04-01-2018, 01:32)feriar napisał(a):
(03-01-2018, 20:50)Aratron napisał(a): Trochę się wyjaśniło. Podłączyłem moduły nrf przez dwa Arduino Uno i komunikują się ze sobą bez problemu. Stwierdziłem więc że nie są w stanie dogadać się między Arduino nano i Uno. Jednak dwa Arduino nano również się nie komunikują. Czy macie pomysł co może być problemem? Zakupiłem całkiem pokaźną ilość nano a chciałbym je wykorzystać w komunikacji.

Pozdrawiam Uśmiech

Ja bym sprawdził czy w ich konfiguracji, tzn. napięcie i częstotliwość wynosi odpowiednio 5V i 16MHz. Bo może być tak, że w wyborze procesora jest przestawiony na 3,3V i 8MHz co może powodować problemy ze stabilnością układu.

A gdzie można to sprawdzić/zmienić? Bo narzędziach w zakładce z procesorami nie ma nic podane.  Huh


Aha, faktycznie bo to są nano to nie można im tak ustawić (pro mini mają taką funkcję) :/ . Powiedz jeszcze jakim napięciem zasilasz Arduino i nRF

Nano zasilam z kabla mini usb ale próbowałem też z baterii AA. Nrf zasilam z wejścia 3,3V nano z podpiętym kondensatorem elektrolitycznym 10uF. Wczoraj gdy próbowałem przesłać informację z jednego nadajnika do drugiego która zapalała by diode czasami dioda mrugała. W pewnym momencie wręcz miałem kontrole przyciskiem i dioda mrugała zgodnie z naciskaniem przycisku. Po chwili jednak komunikacja znowu się przerwała. Tak myślałem że to zakłócenia spowodowane zasilaniem z nano ale są włożone kondensatory i nic to nie daje. Jestem pod ścianą  Ściana
Odpowiedz
#13
Ja bym na twoim miejscu zrobił osobne zasilanie na 3,3V i z niego zasilił nRF bo moim zdaniem CH340 (zakładam że masz klona nano) nie wyrabia prądowo i nie może prawidłowo zasilić układu. Czyli tak: z Arduino wyciągasz 5V i podajesz je na regulator, najlepiej 1117-3.3, przed i za regulatorem daj po kondensatorze 100nF i ten jeden 10uF możesz dać przy nRF. Uśmiech
>> Nie pomagam na PW. Od tego jest forum Uśmiech >> Koniecznie sprawdź: Jak dodawać załączniki

1 problem = 1 wątek
Odpowiedz
#14
Moduły nRF pobierają bardzo mały prąd, jednak rzeczywiście zasilanie 3V3 z klona Arduini Nano może być niewystarczające. Nigdzie nie znalazłem informacji jaką wydajność prądową ma to wyjście. W klonie Arduino Uno jest osobny stabilizator 3,3V. Warto więc spróbować zasilania modułu z osobnego stabilizatora, nawet najprostszego z diodą Zenera.
Odpowiedz
#15
(06-01-2018, 00:22)tom5555 napisał(a): Moduły nRF pobierają bardzo mały prąd, jednak rzeczywiście zasilanie 3V3 z klona Arduini Nano może być niewystarczające. Nigdzie nie znalazłem informacji jaką wydajność prądową ma to wyjście. W klonie Arduino Uno jest osobny stabilizator 3,3V. Warto więc spróbować zasilania modułu z osobnego stabilizatora, nawet najprostszego z diodą Zenera.

ja znalazłem, że ma 25mA na wyjściu, a urządzenie też powinno mieć lekki zapas na peak'i. Sądzę, że to powinno rozwiązać problem Uśmiech
>> Nie pomagam na PW. Od tego jest forum Uśmiech >> Koniecznie sprawdź: Jak dodawać załączniki

1 problem = 1 wątek
Odpowiedz
#16
Dziękuję Wam za odpowiedzi. W przyszłym tygodniu kupię stabilizatory i zobaczymy jakie będą efekty.
Jestem pełen nadziei Duży uśmiech
Odpowiedz
#17
Zakupiłem stabilizatory 3,3V i zastosowałem na obu modułach nrf dodając jeszcze po kondensatorze. Jednak jak komunikacji między modułami nie było, tak nie ma. Nie mam pojęcia co może być nie tak. Macie jeszcze jakieś pomysły może?  Zdezorientowany
Odpowiedz


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Problem z niebieskim LCD 1602A v2.0. Ronin 14 2,427 26-11-2017, 16:44
Ostatni post: feriar
  Arduino - Wyświetlacz sq9krd 1 1,074 13-08-2016, 18:00
Ostatni post: feriar
  Pytanie dot. Merlina i Arduino zawaartur 7 2,449 14-07-2016, 00:41
Ostatni post: feriar

Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości